I decided to install SQL Server 2008 Express Edition, because I want SQL Server Management Studio Express and figure it can't hurt to have the whole SQL Server to play with. One of the dependancies is .NET 3.5 SP1 beta, and while installing it gives this fun recursive error.

dotnet35sp1-error

Oh MS, sometimes you're still better than lolcats.